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SNAP Tutorial 3 – Internet Module

This document is the third of four that aim to instruct the user through the various stages of using SNAP 7. These documents are:

1. SNAP Tutorial 1 – Questionnaire design

2. SNAP Tutorial 2 – Data Entry

3. SNAP Tutorial 3 – Internet Module

4. SNAP Tutorial 4 – Analysing the results
These instructions are aimed at staff and students who want to use Snap to collate data via the internet. Specifically, they cover:

1. Summary of how Snap is used with the internet

2. Before starting – essential things to check

3. Ensuring your questionnaire is web-friendly

4. Publishing

5. Making the survey available to respondents

6. Collating data

7. Setting up Outlook (Appendix A)

1. Summary of how Snap is used with the internet:

1. Snap survey is created 
2. Survey is published as a web survey – this creates a copy of the survey in web file format (html)
3. This html file is made available to respondents, either as an email attachment or as a webpage via the VLP
4. Respondents open the survey in a web browser and submit it via the web 

5. Submitted surveys are collected in your NTU email account inbox
6. Snap compiles returned surveys ready for analysis

2. Before starting – essential things to check:

Create a special folder on h-drive for all Snap related work. This is so that your Snap work doesn’t get “stuck” on one particular PC.

Make sure that you are working on a PC that has MS Outlook configured to access your staff email account. For instructions on how to do this, see Appendix A.

Staff using this method must be aware that replies to their questionnaires MUST be emailed back to the inbox of their university email address. Therefore it may be worth checking that your email account has enough space to handle a large volume of replies, before starting.

3. Ensuring your questionnaire is web-friendly

This section contains pointers on how to make sure that your survey works properly on the internet. 

Instructions

This may sound obvious, but do make sure that the questionnaire is self-explanatory. When testing your web-based version of the survey, make sure that the purpose of the survey form is clear, and include any instructions that may be needed, accounting for the way in which the survey is delivered – either by email or via the VLP.

Formatting single and multiple response questions

A web survey should present a single response question differently to a multiple response question:

	single response questions should use round “radio” buttons, which allow only one option to be chosen:
	
[image: image2]
	multiple response questions should use square tick boxes which allow multiple options to be chosen:
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If you do not specifically tell Snap to do so, it will format single response questions in the same way as a multiple response question when publishing a web version of a survey. This could result in a respondent giving two or more responses to a question only designed to handle one response.

	To specify which type you want to use for each question:
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Click the questionnaire design button:  

2. From the second menu in the survey window, select Response
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Select single or multiple – apply to questions individually

4. Once the web version has been published, check that each question appears correctly, as either single or multiple response
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Sizing Text boxes (open questions and “other” text boxes)

Snap has a tendency to make text boxes too small to accommodate large free-text responses. When publishing survey forms for web use, this can result in long free-text replies being cut abruptly short. To complicate matters, simply enlarging a text box in Snap does not seem to translate into a web-published version that will return all the data typed in. It is therefore important to ensure that text boxes can handle enough data to cope with likely responses.

To do this, try the following:

1. Click the Variables toolbar button: [image: image6.emf]

. The variables window should now appear:
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2. If necessary, enlarge the window so that you can see the Length column. This contains the number you need to check – it shows the number of characters that a question response can contain.
3. Find the question that you’re working with, and double click on it. The following dialogue box should now appear:
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4. In the Length box, type in the number of characters you feel will be sufficient (up to a maximum of 9999).

You should now find that the on-screen size of this box has been increased, and that any long replies given in the published survey are not cut short.

Limitations:

Use of the following features is not advised when creating a Snap internet survey due to the complexity it involves for respondents (they involve creating more than one file):

a. Validation 

b. No Replies 

c. Dynamic text

d. Go to statements 

e. Images

4. Publishing

Once you are happy with your survey you can publish it for use on the internet. If your initial attempt is not satisfactory, it is easy to re-publish after testing your first attempt.

If necessary, move the survey to the H drive.

Make sure that your survey is in Questionnaire Design Mode (click this toolbar icon:
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). 

In the File menu > Publish Web survey. The Web Survey Configuration dialogue box should appear as shown below, with the Basics section:

	1) Basics section:

Access name – enter the name of the survey here. If sending as an email attachment, this is the name of the html file that respondents will see when they activate the survey. To avoid confusion when collating data, include the module name in the Access Name, so that if you are collating data from more than one survey, replies to each one can easily be identified.
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Output path – enter the name of the drive and folder where you want to store the html file (this should be in the same folder on your h-drive as the Snap file). If necessary, use the Browse button to find the correct folder.

Image Sub-Path – this is not needed.

	2) Replies section:

Script Location – this should automatically be set to http://www.Snapsurveys.com/cgi-bin/subques.pl, as shown above. This ensures that the survey can access a script hosted on the internet at the Snap website, that allows Snap to compile the completed responses. 

Email Response Recipient – enter your email address here in full (this is the address to which responses will be submitted).
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Web Page after Submitting – leave this box blank unless you have a specific page you want respondents to go to directly after completing the survey.

The remaining sections (Interview, Layout, Buttons etc) can be ignored. Click OK to complete the publishing process.

Checking your html file

Open a web browser (preferably Internet Explorer) and open the published html file:

1. File menu
2. Select Open
3. Click the Browse button
4. Open the drive and folder that contains the html file, and open the file itself
Scroll through the file in the browser. Some points to look for:

· Single response questions should use circular Radio buttons.

· Multiple response questions should use square tickboxes.

· Text boxes – check that these are both physically big enough on screen, and that they are big enough in terms of the amount of data they can accept.

· Layout - when Snap creates the html version of the original Snap survey, the layout is prone to small changes – check that the layout still resembles the original Snap file, and that questions and their component parts are in the correct place. 

If changes need to be made it is possible to go back to Snap and edit the original survey, and then republish. 

5. Making the survey available to respondents
It is vital that once the survey is made available to respondents via email (or any other means) that the original Snap survey file is not altered, as this may affect Snaps ability to collate data correctly. Therefore make sure your survey is thoroughly checked before you reach this point, because from now on changes to the original risk making any data you collect unusable.
Using Email

1. Create a new email message in your university email account, using MS Outlook

2. Add the addresses of the respondents that you want to include

3. Add explanatory text including any instructions that may be needed for respondents to complete the survey

4. Attach the html version of the survey (click attach file button [image: image12.png]


) and send the message

Uploading to the VLP

There may be circumstances when it may be better to distribute your survey via the web, rather than via email. To do this you will need webspace to host your survey web page. 

For staff, the most likely option is to upload a survey to the VLP (particularly in the example of student feedback surveys). For a guide showing how to upload documents to the VLP, please refer to “Uploading documents in modules” available at https://elearn.ntu.ac.uk/mle/system/support/getheader.asp?fileid=29, in the Support Guides section of the VLP.

Once the file is in the VLP, it should appear in the list of documents for your chosen module. All students have to do is click on it, as they would to access any other document, and the survey should appear in a new browser window.

6. Collating data

In Outlook:
Completed responses are sent back as email messages to the inbox of your university email account (the specified Email Response Recipient mentioned on the previous page). The messages themselves may look complex, but don’t worry – Snap interprets the content.

For Snap to be able to use these responses, they must be in the inbox. It is possible to move responses to another email folder prior to collating them, but at the point where you want to collate them they must be put back in the inbox.

They must also be left as unread – as symbolized by this message icon:  [image: image13.png]



1. If they have been read (showing the message read icon: [image: image14.png]


) then change them back to being unread – do this by:

2. Right clicking on a required message
3. Click the Mark as unread option on the menu that appears. The message icon should now change to Unread [image: image15.png]


.
In Snap:

	1. Open the original survey. Click the Case Data button, circled here: 

2. (Don’t confuse this with the identical looking Data View button underneath it!)
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	3. Go to the File > Import. The Data Import dialogue box should now appear:

4. In the Format menu, select MAIL format, as shown here, and click OK.
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Snap will now scan your inbox for emails that contain survey data. In the process, the following dialogue box may appear several times:


5. 
Click Yes to clear this box each time:

	Once complete, Snap will show the following button, showing the number of responses (Cases) it has received from your inbox: 

Click Done, and check your new case data in Snap.
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7. Appendix A - Setting up Outlook

For Snap to work with internet delivered surveys, you need to use a PC that has Snap and a fully set up copy of MS Outlook. While Outlook is standard on all NTU machines, it may not be set up to see your email account. These instructions allow you to set up Outlook to do this.

	Start Outlook.

The Outlook 2002 startup dialogue box should appear, as shown here. Click Next. 

You should then get asked to configure email accounts. 

Select Yes and click Next.
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The E-mail Accounts dialogue box should appear. Select Microsoft Exchange Server, and click Next.
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In the first text box, enter the word Cherry, and your first and surnames (separated by a space) into the second. Click Next. You should now get a congratulations message. Click Finish. 

In Outlook, go to the View menu, and select Folder List. You should now be able to see all your messages and folders, meaning that Outlook is now ready for you to work with Snap.
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